The way Art.style is currently implemented is a thron in my side since a long while. I do not like the excessive nesting, e.g.
path.style.stroke.width = ...
The reason why I have implemented it that way was to give the possibility to copy only the stroke style from one object to the other, or only the fill style. But probably this is not used so often, and it could easily be offered through two functions?
I am currently considering making it more like the style property in CSS, so only with one hierarchy of objects bellow style:
art.style.fill.color -> art.style.fillColor art.style.stroke.width -> art.style.strokeWidth
And while at it, we could also consider getting rid of style completely, e.g. art.fillColor, etc.
Also, I am not happy with the overlapp of characterStyle and style in all TextFrame based objects, and with the naming characterStyle in TextRange, that could as well just be called style.
But before I change anything, I wanted to hear the your opinions on this here.